Another Tracker4 not working as expected

The Tracker 4 has not performed out of the box as expected.
I have set the My Call and can set my home wifi info via the web interface.

The web interface is nothing like the manual suggest, see image attached.
And the Update for the WiFi fails, see console output below.
The Version page of the web interface does not reflect anything like the numbers of the latest version.

In short either I am missing something or the T4 I received has some programming issues.
If anyone can shed some light on these issues I would be very appreciative.

Warren vk3byd

Edited Console output

Tracker4 - Copyright 2018 Argent Data Systems, Inc.
Firmware revision 161

cmd:< WiFi: Connected to access point `xxxxxx', IP >
cmd:< Network is up. >

cmd:Checking for updates...
WiFi FW version 48 available. Downloading...
Fetching 1048604 bytes

Downloading firmware version 162...
Fetching 362316 bytes

Loading WiFi firmware build 0
< DFU: Starting WiFi update process >
cmd:< WiFi: Disconnected >
cmd:< DFU: Loading 1048576 bytes >
cmd:WiFi update failed, error 8
WiFi update fails to Load

Loading firmware version 162...
Please wait at least 15 seconds before removing power!
Tracker4 - Copyright 2020 Argent Data Systems, Inc.
Firmware revision 162, compiled Dec 24 2019

I note the other thread re issues with version 162, and I have reloaded ver 161.



Hi Warren,

I agree the URL that you are hitting is not the correct URL for the Tracker4 'portal'.
Your URL based on what you have provided should be:
Just adding here... it appears that Hyperion is the name of the (Oracle) web server software. I tried getting to the hyp-controls view you had and although it loads, not with the options/view you are seeing. That does seem to me to be some malfunctioning configuration.

How did you find, or re-upload the prior firmware version?
I'd like to at least duplicate your issue since I'm in a broken state anyways. Always willing to play along...

That being said, you should try connecting via USB/console cable and running the two commands (shown in the manual) WIFI RESET and then followed by the update command to see if it then re-applies the wifi firmware update as part of the update process.

---- update ----
Just found an old post from Scott with FW 145. I used the loadfw command and voila - blinking green light... yay!

And just verified that my gps is functioning again. So definitely can validate this is a firmware issue - not hardware.

Now that I know I can up/down fw versions at will... let's run the update again just for fun.
And guess what, just as expected - no lights, no gps
So for now, I'll hop back to 145 until I can find other versions...
BTW - keep these on your Tracker4, just rename them to tr_145.bin and t4_162.bin etc. Had I thought of this before applying the fw update, I would have saved 161.
Last edited:
Thanks Conrad,
The tracker4 arrived here just after christmas, and was like this straight out of the box.

The URL, #hyp-info changes nothing, not even a cannot find the page etc. I just stay on which ever page I am on when I type that url in.
If I start from a completely different url, and then enter I get the same home page as I always do.
Page 8 of the tracker 4 manual has the url as; /files/index.html#hyp-controls, I get a "not found" for that one.

As for down grading the firmware, I used LOADFW on the console port and brought it back. I had also (as you suggest) saved the original firmware files with a new name. But it appeared to me that it did not over write the original t4.bin file.

I have done all of my updates via the console as the "update" button on the Update tab does not work, ie will not let me click on it.
I will hang off on the wifi update for now, in the interest of not braking it further : )

Hi Warren -

If you haven't tried the 161 firmware, I'd give that a try. It sounds like yours is a mess. I posted the 161 firmware over on another thread here about a week ago. t4-161.bin was the name. Do not use the 162 build, it kills gps and maybe other things.

Cheers and 73 - Jon N7UV
Hi Jon,
Mine came as Version 161, and the RF and GPS section seems to work.
As best I can tell its just the web interface, that does not.
I have emailed the support email address as suggested by Scott but still waiting on a response.

I am very disappoint with the device, for something that I had plan to replace an MFJ1270 running Ui-Digi with.
To be honest the MFJ is running rings around it at the moment

Warren vk3byd
Hi Warren -

Given the peculiar version control evidence that I see in yours, I was just thinking it'd be interesting to re-flash it with the 161 version that came in mine. Not saying it would change things, but one never knows. The GUI yours shows is a GUI for another product line of ADS, completely unrelated to APRS.

I share your frustration with the product and the lack of any support but from those in the community attempting to get this to do something. Good luck!

Cheers and 73 - Jon N7UV
Hi Jon,
OK, so I have loaded your version 161, and have the same results with the web interface.
Thanks for the comment on the GUI.
Is the GUI going to be part of the "hard coded firmware" or more like a separate, configuration file?

Warren vk3byd
Sorry to hear, Warren, that it didn't do something special. That's interesting that the firmware isn't everything, that there must be some base image on board that doesn't get updated. Well, it was an experiment.

Cheers and 73 - Jon N7UV


Staff member
There appears to be an updated version of firmware located at
Mines still a brick with firmware v 135 in it due to an interrupt that wasn't getting disabled during the update process, so I can't update mine.
Hmm that was 20 months ago - 'spose I should figure out how to talk to it via JTAG seeing as the country's in lockdown for a bit & it appears that I have spare time now...
Hi Ian,
Thanks for the info, I have grabbed the V163 update, and the web interface issue is still there.
Reading Scott recent post re the firmware update (v163) I am still not sure if the web interface issue I have is a feature of something I have loaded or not.
Good Luck with yours.
73 Warren.

Scott Miller

Staff member
Hi all,

Pardon the duplication, but I'm going to try to hit every open thread.

Please consider this forum to be strictly peer-to-peer discussion for now. For anything that needs an official response, please contact We're tracking all tickets through Zendesk there. I won't guarantee that everything will get handled immediately, but we can at least see and keep track of it all.

There are just two of us working on the radio side of things for now and that's not likely to change while Covid is still a thing. We've at least reached something like a steady state, even if it's still exhausting. Macrofab in Texas is now handling some of our assembly so that's taken some load off, but the holiday season is likely to have us scrambling again.

For any software issues, try the 'update' command first if that's working for you. If it's not or if it's not connected to the internet, you can grab the latest files (as of 11/19/2020) here:

Copy them both to the tracker. From the console, run:

wifi load t4-wgm.bin
loadfw t4.bin
If whatever problem you're having persists, please email I'll try to check back here as time permits.