APRS SmartBeacon on build 161

I spent a few hours today attempting to get SmartBeaconing running on build 161. All attempts failed.

Using the GUI, I set Settings>Tracker>SmartBeacon on. I set the default beacon rate to 60 s, the low speed to 4 mph, the fast speed to 30 mph, the turn trigger to 23 deg, and the fast rate to 10 sec (also tried 15 sec). I rebooted the thing several times. I drove down the street at 40 mph, well over the SmartBeacon maximum setting. At no time did the beacon rate change from the default. Very frustrating.

I did notice that on the GUI Info screen, it showed accurately what my speed and heading was. However, the speed is in knots, which is ok but not so interesting, and as I think someone else pointed out, there doesn't seem to be a way to change the units set. It's nice to know that when it shows 60 that means in 360 hours I'll circumnavigate the globe, Not so useful driving to the grocery store...

My only other APRS radio is the Yaesu FT-2DR. One thing of significant interest I discovered today is that my default setting of GUI>Radio>Transmitter to 1000 mV level was too much for the Yaesu to decode, and in fact it wouldn't even break squelch for it. I tinkered with it, lowering it to 500 mV, which worked fine, then 700 mV, which didn't work at all, then 650 and ultimately 600 mV where it's set now and that seems to work fine. So yet another little thing that is tricky.

I was running YAAC on the truck PC. Sadly, today after attempting to configure YAAC to talk to the T4, YAAC up and found some start where it does a hard crash to the YAAC program, and I'm attempting to sort that out. But, I was on the way to having YAAC talk to the T4 over the serial USB interface when YAAC died.

If it's not one frustrating thing, it's always another %^)

Cheers and 73 - Jon N7UV

Scott Miller

Staff member
Hi all,

Pardon the duplication, but I'm going to try to hit every open thread.

Please consider this forum to be strictly peer-to-peer discussion for now. For anything that needs an official response, please contact support@argentdata.com. We're tracking all tickets through Zendesk there. I won't guarantee that everything will get handled immediately, but we can at least see and keep track of it all.

There are just two of us working on the radio side of things for now and that's not likely to change while Covid is still a thing. We've at least reached something like a steady state, even if it's still exhausting. Macrofab in Texas is now handling some of our assembly so that's taken some load off, but the holiday season is likely to have us scrambling again.

For any software issues, try the 'update' command first if that's working for you. If it's not or if it's not connected to the internet, you can grab the latest files (as of 11/19/2020) here:


Copy them both to the tracker. From the console, run:

wifi load t4-wgm.bin
loadfw t4.bin
If whatever problem you're having persists, please email support@argentdata.com. I'll try to check back here as time permits.