Tracker4 build 144 posted

Scott Miller

Administrator
Staff member
#1
I've posted firmware build 144 for the Tracker4 (and attached a copy here). I think this ought to finally fix the intermittent lockup bug that's been holding everything up for months. Please give this a try if you have a T4 and report back. If we don't have any crashes for two days, we'll start shipping the T4s again and I'll get back to working on new features.
 

Scott Miller

Administrator
Staff member
#5
Found the source of the problem. Amazingly enough it wasn't something stupid I did! Someone screwed up the RTOS port and opened up a very small window for a race condition. The incorrect code was definitely deliberate and not a typo, it's just not clear if it was a temporary thing that someone forgot to fix or if they just overlooked the implications of what they were doing.

Now to start shipping trackers again...
 

K4HG

New member
#6
Well done! I’m at 42 hours without a crash. I guess this means we can start asking for features without feeling guilty. My first would be a GPS quality indicator, ideally in the top status bar but at least on the info page, either satellites locked or DOP. But you can have a half hour off to celebrate your accomplishment first! ;-)
 

Scott Miller

Administrator
Staff member
#7
I knocked off early at 8:30 on Tuesday night to celebrate. =]

What I need is a GPS antenna on the roof so we can actually get a signal here in the lab. The roof's at least 30 feet up and there's no convenient routing, so that's a lot of good coax to run.

I'm planning to eventually do the standard polar plot of satellites, too, but I decided that one wasn't that important.

Right now I'm scrambling to deal with the enclosure printing situation. The flatbed printer is still down and could stay that way for a while if it needs parts, so I'm trying to find someone else locally to print all of the panels.