Tracker4 - Wifi drops and very short range... Resolved

Just got my Tracker4 on 01/20/20. WiFi range was very short, like a few feet. Connection would drop. Tried a high gain WiFi antenna. No improvement so I suspected a connection problem.

Checking the connectors, I see my Tracker4 has a SMA Female Connector (no pin). It should be a RP-SMA Female Connector (with a pin). Standard WiFi antennas use a RP-SMA Male Connector (no pin) so the WiFi antenna doesn't connect to the center connector on the Tracker4 because both connectors do not have a pin. I don't know if I got the only Tracker4 with the wrong SMA gender but if others are having problems with WiFi, they should check the connectors.

I ordered an SMA gender adapter ((HIGHFINE SMA Male Plug (Pin) to RP-SMA Female (Pin) Coupling Nut Connector Adapter)) via Amazon. Installed the adapter. Range and drop problem is resolved. My Tracker4 is now located about 50 feet away in an outside radio shack. Ran 24 hours with no drops.

James N5XRQ
Good evening James -

As I'm having some intermittent Wi-Fi issues, your note was enough for me to have a peek at the Wi-Fi connectors on my two T4 devices - one delivered back in September and the one delivered a few weeks ago. Both have the standard RP-SMA (pin on the chassis side, pin socket on the antenna side) setup. So I guess you're special!

Cheers and 73 - Jon N7UV
Hey James et al -

I have been doing some relatively painful experimenting with the Wi-Fi function in the T4.

First, getting the Wi-Fi network to start as client is not straightforward. I connect to the box via USB from a Windows 10 PC.

As an aside, I have never been able to get the T4 to join any Windows 7 device via USB. Although the manual claims there's an appropriate .inf file on the flash drive, and the website or somewhere on this forum points to a claimed appropriate file, my Windows 7 boxes (of which I have a ton of) never recognize the USB serial connection. So, in order to do the troubleshooting on this darned thing, I actually had to build up a new Windows 10 box just so I could get the USB running. Pretty sick, huh?

Ok, back to Wi-Fi networking. I surf in via PuTTY to the T4. I issue the command "wifi" to see what mode the thing is in. I believe it started out in Wi-Fi Direct mode, and while reading an old post of mine from September I seemed to be able to get that to work, on this T4 with build 161 I haven't been able to get Wi-Fi Direct mode to work. More on that later.

After the "wifi" command, I type "wifi mode client", and get no acknowledgement that it took. Typing "wifi" again often shows it's still in Wi-Fi Direct mode, so I do the "wifi mode client" a couple of times, and ultimately it goes to client mode. Maybe I'm just impatient, because you'll see later that it takes "forever" (I'm impatient) to do something with the Wi-Fi device.

Once in client mode, I try to quickly type in "wifi connect myaccesspointname mywifipassword". It acknowledges that command with something like "connecting". However, this is where my impatience has affected my perception of the device. It does appear to ultimately join my network as a client, but can take several minutes (doing what I don't know) before it responds with something like "connected". Today, I did the command, then unloaded groceries (and paper towels!!!) from the truck and by the time I was done the Wi-Fi client connection had been up about 6 minutes. This is reliably consistent, to the best of my experience.

Now that I've got it in client mode, I can surf in to the GUI at the IP address shown as response to the "wifi" command. And there, under Settings>Network, I configure it as follows:
The first network is my home network, and the second network is my other home's network. Then, I set up the Wi-Fi mode type as follows:
So this "should" cause the T4 on boot to try to join one or the other of my two networks. And like I said earlier, it takes several minutes from booth to have that happen. It's important for me to be patient...

With the above setup, I can cycle power to the T4 and except for the long delay in joining it appears to work each time. Yeay!

Yesterday, with this setup, I was able to join my home network and then drive to the other house and have it join that network as well. Just slow. I have not done anything yet to force a fixed address for the device (mainly so it's the same address no matter which house it's joined).

While Wi-Fi client mode is great for the situation where I'm near my own networks, and I can pull a GUI from a real computer at either end and configure the T4, it's not much use when I'm mobile. There, I'd prefer it to be an AP, and for me to be able to join it from my truck PC. (Actually, I'd prefer having a wired network port on the T4, but that's asking too much...)

Yesterday, using the GUI I set up the T4 to create its own network and act as an AP, like this:

The settings would appear to set up the T4 to start up as an AP and allow client devices to join it. That way, in the truck, I could join the T4's network wirelessly, and gain access to the GUI, and be able to run an APRS client on the truck PC that attaches to the T4 as a client and connects to the T4 via KISS over TCP. Simultaneously, I could use the "Enable NMEA over KISS" function to have a real-time NMEA stream for the APRS client. I think I also have to disable "Enable KISS over USB", so that the NMEA data stream isn't punctuated with KISS packets every few second. At least that's my idea.

So far I have not been able to get this to work, but I also have to state that I haven't tried very hard to do so.

So now for Wi-Fi Direct Mode. Going back to the GUI, I set up the device as follows:
AFAIK, that tells the T4 to start up in Wi-Fi Direct mode. So, rebooting the T4 and watching on the USB serial port, I see the usual received packets then a message something like "starting Direct mode" or similar, and then the T4 seems to go quiet for a while. Minutes? During that time, my beacon transmissions show up on the serial port, but it doesn't key the radio, and I hear no received packets. After a while, received packets start to show up on the serial port, then there's a message something like "restarting wifi direct mode" and the T4 appears to pause all the other things again. This goes on and on. At the same time, while it's doing this, I try to join via Wi-Fi Direct from the truck computer, the T4 SSID shows up in my available wireless networks list, but clicking on it and attempting to join is unproductive. Notice that in the above figure, the Password for incoming client connections shows SSID, I'd prefer it to be something different, but have not been able to change it successfully yet. In any event, assuming my Network Name is abcd1234Test it looks like the password is abcd1234Test as well, but the mobile PC just doesn't seem to be able to join. This is particularly annoying. And I've seen no writeup about how the network functionality really works, and based upon actual device test rather than how it should work in theory...

So, that's where I am right now. I'm going to try again to put it into AP mode, and see if it does show up and if I can join it as a client. This mode seems most useful for my purposes, but each day that passes I see less and less utility in these features, especially if they don't work.

More later.

Cheers and 73 - Jon N7UV


Well, that was quick. After setting up the T4 as indicated before for AP mode, I rebooted it, found it on my iPhone, and joined the network. The iPhone Chrome browser was automatically directed to the T4 GUI, and the GUI is working fine. This is good news.

Now, I will take the whole thing out to the truck, and see if I can replicate this success out there.

Cheers and 73 - Jon N7UV
Spoke too soon. The iPhone was connected to the T4 GUI but just like you'd join a hotspot where you have to do something before the phone can connect. There was a "DONE" button in the upper right, and when I clicked on that, the iPhone said something like "do you want to continue to be connected to this network without network access?" of course I said yes, and it dropped the AP connection and went back to my home network. Grrrrr.

On the iPhone, I again searched for the T4 Wi-Fi network, found it, and this time it joined it without the popup screen, and now the iPhone is reliably communicating as a client on the T4 network.

Ok, now that I know it can be ornery, I will drag it out to the truck and see what happens.

Cheers and 73 - Jon N7UV

Scott Miller

Staff member
Hi all,

Pardon the duplication, but I'm going to try to hit every open thread.

Please consider this forum to be strictly peer-to-peer discussion for now. For anything that needs an official response, please contact We're tracking all tickets through Zendesk there. I won't guarantee that everything will get handled immediately, but we can at least see and keep track of it all.

There are just two of us working on the radio side of things for now and that's not likely to change while Covid is still a thing. We've at least reached something like a steady state, even if it's still exhausting. Macrofab in Texas is now handling some of our assembly so that's taken some load off, but the holiday season is likely to have us scrambling again.

For any software issues, try the 'update' command first if that's working for you. If it's not or if it's not connected to the internet, you can grab the latest files (as of 11/19/2020) here:

Copy them both to the tracker. From the console, run:

wifi load t4-wgm.bin
loadfw t4.bin
If whatever problem you're having persists, please email I'll try to check back here as time permits.